Javaに関する様々な情報をご紹介します。

Javaに関する様々な情報をご紹介します。
評価

0

Eclips起動時のエラーで困っています。

Eclips起動時にアイコンをクリックすると次のエラーが出るようになりました。
現在PCにインストールしているJDKのバージョンはjdk1.5.0_05です。色々な書籍に添付されているCD-ROMでインストールしても同じ現象で、よく意味がわかりません。
<エラー内容>
 「Rquired Java version1.4.1. Available:1.3.1」

です。以前は正常に使用できていました。
原因は何でしょうか。また。現在インストールしている「jdk1.5.0_05」ではダメなのでしょうか。
よろしくお願い致します。

6

回答

89463

閲覧

6件の回答

評価

0

Java VMのデフォルト設定はどうなっていますか。

評価

0

それから。Java5は、update6が最新なので、更新しましょう。

余計なことですが、eのキーの調子が悪いんでしょうか。
Eclips「e」、R「e」quiredですが。

評価

0

mio様、回答、有難うございました。
「Java VMのデフォルト設定・・・」これは、
インターネットオプションの<詳細>で「Microsoft VM」に
チェックが入っていれば良いでしょうか・・・。
その他設定場所、確認場所がありましたら、お教えください。

<キーボードですが・・・かなり「ボロ」になっています・・・。> 

評価

0

環境変数PATHの先頭に jdk5をインストールしたディレクトリ\bin; をセットしてください。

(eclipse.exeがkickするjavaw.exeがこっそりインストールされてしまった1.3のものになっているという話でしょう。そういう悪戯をするソフトは私はOracleしか知りませんが。JDeveloperとかOracleClientとか。↑で不都合が出るようなら
起動オプション - EclipseWiki
http://www.eclipsewiki.net/eclipse/?%B5%AF%C6%B0%A5%AA%A5%D7%A5%B7%A5%E7%A5%F3#content_1_1
で)

評価

0

 FE様、ありがとうございました!
実は[ORACLE9i]のトライアルをインストールしました!
確か現象が発生したのはその後ぐらいからの起動だったと思います。帰宅後(夜)にお教え頂いた方法でやってみます!
ありがとうございました。

評価

0

FE様、「java -VM javaw.exeを指定」の方法で起動できました。
有難うございました。「環境変数PATHの先頭に jdk5をインストールしたディレクトリ\bin; をセット・・・」の方法ですが、
PATHの先頭にJDK5のbinをセットしましたが、現象はかわりませんでしたので、コマンドでの起動にしました。どちらにしても、起動できれば良いので。
本当に、有難うございました。
返信をいただきましたmio様も、有難うございました。

質問から6ヶ月以上経過しているので、回答を書き込むことはできません。