Javaに関する様々な情報をご紹介します。

Javaに関する様々な情報をご紹介します。
評価

0

gosenとLuceneのバージョンの関連性について

Apache Lucene4.10.0とLucene-gosen4.10.0の関連性につ
いて質問させてください。

現在Apache Lucene4.10.0とLucene-gosen4.10.0を利用し
てインデックスを作成しているのですが、
以下のようにインデックス化されます。

文書ファイル
→「文」「書」「ファイル」


辞書も調べましたが特に問題は無いようです。
また同様の現象がないか検索しても、該当するものはあり
ませんでした。

そこでバージョンの互換性が問題なのではないかと思い当
りました。
lucene-gosenのダウンロードサイトにおいて、
過去バージョンのlucene-gosenのバージョンとApache 
Luceneのバージョンが同じ数字だったため、
4.10.0同士であれば対応していると考えていました。

4.6.0まではコメントから同数で正常通りに動く事はわか
りましたが、それ以降のバージョンは確認方法が無く、検
索してみてもバージョン数の関連性について記載している
サイトが有りませんでした。

唯一近いものとして、以下の記事を発見いたしましたが、
確証には至りませんでした。
http://blog.johtani.info/blog/2014/01/28/release-
lucene-gosen-4-dot-6-1/


そこで質問なのですが、Lucene-gosenとApache 
Lucene4.10.0のバージョン数は対応している(Lucene-
gosenがApache Luceneに合わせている)のでしょうか。

または、Lucene-gosenがApache Luceneのどのバージョン
に対応しているか確認する方法を教えていただけないでし
ょうか。


3

回答

1715

閲覧

3件の回答

評価

0

一個前のバージョンで試してみては?
まぁ結果が違っても、イコールサポートバージョンというわけで
はないけど。

評価

0

回答ありがとうございます。
複数のバージョンを確認してみましたが、
バージョン毎に結果が異なっており、どれがサポート対象な
のかわからない状態です。

サポートバージョンなのか確認出来れば、
原因がlucene側なのかそれ以外なのか判るのですが…。

宜しくお願い致します。

評価

0

ところで、何で開発側に聞かないの?

質問から6ヶ月以上経過しているので、回答を書き込むことはできません。