Javaに関する様々な情報をご紹介します。

Javaに関する様々な情報をご紹介します。
評価

0

Eclipse プラグイン開発について

私が携わっている環境(某ツール)にて、Javaバージョンアップ(7.45から8.45)に
伴い(某ツールの)Eclipseの開発環境についてもバージョンアップを実施したのですが、
以前動作していたものが動作しなくなりました。
どなたかご教授お願いします。
初心者で質問自体どこからお聞きしてよいのか、
的を得ていないかもしれませんが、宜しくお願いします。


【開発環境】
★Windows7 64bitPC
★ターゲットプラットホーム(プラグイン)開発

【バージョンアップ手順】
?クライアントインストール手順書に従い
某ツール自体をJava8用にバージョンアップ

?Eclipse環境を構築
デバッグ実行でエラーとなる

【バージョンアップ前】
JRE→7.45
JDK→7.45
Eclipse→4.3

【バージョンアップ後】
JRE→8.45
JDK→8.45
Eclipse→4.5

Eclipseでは某ツールのターゲットプラットフォームの
Pluginを参照するように設定する

【私自身が気になるところ】
某ツールのターゲットプラットフォームの
Plugin内に、数々のEclipseプラグインが含まれている
が、バージョンがJava7用のような気がしています。
最近Javaに携わったばかりではっきりと断定できないでいます。

例えば、 バージョンアップ後、ターゲットプラットフォームの
Plginに    org.eclipse.ui (3.8)が存在するが、
これはJava8で動作可能かどうか、など、Eclipseのバージョンと
Javaのバージョンの関係性等が疎いです。宜しく
お願いします。

2

回答

4727

閲覧

2件の回答

評価

0

追記です。
org.eclipse.uiのバージョンについてEclipse4.5では、
3.107となっていますが、3.8で代用して動くかどうか、
又、org.eclipse.uiの3.8はJava8.45で動くかどうかについてもご教授頂けると幸いです。

評価

0

>エラーとなる
一体どんなエラーなんだか。

質問から6ヶ月以上経過しているので、回答を書き込むことはできません。