Javaに関する様々な情報をご紹介します。

Javaに関する様々な情報をご紹介します。
評価

0

poiを呼出すとNoSuchMethodError

dbunitからpoiを呼び出すとNoSuchMethodErrorが出てしまいます。
java.lang.NoSuchMethodError: org.apache.poi.hssf.usermodel.HSSFWorkbook.setSheetName(ILjava/lang/String;S)V
at org.dbunit.dataset.excel.XlsDataSet.write(XlsDataSet.java:83)

dbunitとpoiのバージョンが合っていないのではと考えています。
dbunitとpoiの動作可能なバージョンの組み合わせを教えてください。

現在、私が使っているバージョンは以下です。
dbunit:2.1
poi:3.8

よろしくお願い致します。

1

回答

13515

閲覧

1件の回答

評価

0

http://www.dbunit.org/dependencies.html
ここでは org.apache.poi は 3.2-FINAL になってますが。

質問から6ヶ月以上経過しているので、回答を書き込むことはできません。