Javaに関する様々な情報をご紹介します。

Javaに関する様々な情報をご紹介します。
評価

0

EclipseでStrutsを使う。

バージョンはEclipse3.4とStruts1.3.10を使います。
EclipseでStrutsを使うにはどうしたらよいでしょうか。Tomcat、Eclipseは入れています。Strutsをインストール後、Webで調べる限り、Strutsの何らかのファイルをTomcatのディレクトリに入れるようなことが書いてありましたが、うまくいきません。

3

回答

7003

閲覧

3件の回答

評価

0

>Strutsの何らかのファイルを
何のファイルと書いてありましたか?

>うまくいきません
もう少し詳しくどうぞ。

評価

0

説明不足ですいません。現時点ではダウンロードしたstruts-1.3.10-all.zipからstruts-blank-1.3.10.warを解凍するところまでできています。

参考にしているサイトは
http://muimi.com/j/eclipse/struts01.html
です。

このサイトの中に、「struts-blank.warを解凍します(jarコマンドか、warをzipにして解凍ツールを使ってください)。解凍されたファイルの中の、WEB-INFディレクトリとindex.jspを、先ほど作ったstruts-test01フォルダに上書きします(META-INFは不要です)。 」という解説があります。struts-test01フォルダというのはTomcatプロジェクトです。

そこで私は、Eclipseを起動し、ファイルタブから新規>その他、「ウィザードを選択」からサーバーを選択し、Tomcatサーバーのプロジェクトを作りましたが、ここまではあっているでしょうか?

そして、作ったTomcatプロジェクトの中身をプロジェクト・エクスプローラーで確認しましたが、WEB-INFディレクトリとindex.jspというのはありませんでした。

はまっています。宜しく御願します。

評価

0

テキスト通りのバージョンを用意するか、
使用するバージョンに合わせたテキストを用意するか、
どちらかにしましょう。

質問から6ヶ月以上経過しているので、回答を書き込むことはできません。